import re
regex = re.compile(r"^(?<nthBase>[+-]?\d+)(?:\*?(?<series>n)(?<crementer>[+-]\d+)?)?$", flags=re.MULTILINE)
test_str = ("2n+1\n"
"2n\n"
"444\n"
"-22\n"
"+4n\n"
"-5*n\n"
"-5*n-3\n"
"-5n+44\n"
"--5\n"
"++5\n"
"-\n"
"+\n"
"-6-1\n"
"62-1\n"
"62n-1\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")