#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(postgresql:\/\/)?([a-zA-Z]{2,}(@)?[a-zA-Z]{2,}):([a-zA-Z]{2,}(@)?[a-zA-Z]{2,})(.+):(\d{4,})\/([a-zA-Z]{2,})"
Local $sString = "postgresql://admin@name:mypassword@name.postgres.database.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.com:5432/postgres"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")