// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(postgresql:\/\/)?([a-zA-Z]{2,}(@)?[a-zA-Z]{2,}):([a-zA-Z]{2,}(@)?[a-zA-Z]{2,})(.+):(\d{4,})\/([a-zA-Z]{2,})").unwrap();
let string = "postgresql://admin@name:mypassword@name.postgres.database.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.com:5432/postgres";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}