re = /(postgresql:\/\/)?([a-zA-Z]{2,}(@)?[a-zA-Z]{2,}):([a-zA-Z]{2,}(@)?[a-zA-Z]{2,})(.+):(\d{4,})\/([a-zA-Z]{2,})/
str = 'postgresql://admin@name:mypassword@name.postgres.database.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.com:5432/postgres'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end