package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(postgresql:\/\/)?([a-zA-Z]{2,}(@)?[a-zA-Z]{2,}):([a-zA-Z]{2,}(@)?[a-zA-Z]{2,})(.+):(\d{4,})\/([a-zA-Z]{2,})`)
var str = `postgresql://admin@name:mypassword@name.postgres.database.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.azure.com:5432/postgres`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}