import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[table]\\R*([^[]*(?:\\[(?!/?table])[^[]*)*)\\R*\\[/table]";
final String string = "\n"
+ "[b]Check out this demo[/b]\n"
+ "¯\\_(ツ)_/¯\n"
+ "[table]\n"
+ "[**]header1[||]header2[||]header3[||]...[/**]\n"
+ "[*]child1.1[|]child1.2[|]child1.3[|]...\n"
+ "[*]child2.1[|]child2.2[|]child2.3[|]...\n"
+ "[*]child3.1[|]child3.2[|]child3.3[|]...\n"
+ "[*]...[|]...[|]...[|]...\n"
+ "[/table]\n"
+ "simple text\n"
+ "[table]\n"
+ "[**]a 1[||]and a 2[/**]\n"
+ "[*]A[|]B\n"
+ "[*]C[|]D\n"
+ "[/table]\n\n"
+ "[s]3, you're out[/s]\n"
+ "blah";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}