import re
regex = re.compile(r"\[table]\R*([^[]*(?:\[(?!/?table])[^[]*)*)\R*\[/table]")
test_str = ("\n"
"[b]Check out this demo[/b]\n"
"¯\\_(ツ)_/¯\n"
"[table]\n"
"[**]header1[||]header2[||]header3[||]...[/**]\n"
"[*]child1.1[|]child1.2[|]child1.3[|]...\n"
"[*]child2.1[|]child2.2[|]child2.3[|]...\n"
"[*]child3.1[|]child3.2[|]child3.3[|]...\n"
"[*]...[|]...[|]...[|]...\n"
"[/table]\n"
"simple text\n"
"[table]\n"
"[**]a 1[||]and a 2[/**]\n"
"[*]A[|]B\n"
"[*]C[|]D\n"
"[/table]\n\n"
"[s]3, you're out[/s]\n"
"blah")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")