using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d+)";
string substitution = @"<span>\1</span>";
string input = @"strings[abc123def456]strings";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}