$re = '/(\d+)/';
$str = 'strings[abc123def456]strings';
$subst = "<span>\1</span>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;