import Foundation
let pattern = #"(\d+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"strings[abc123def456]strings"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<span>\1</span>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)