use strict;
my $str = 'strings[abc123def456]strings';
my $regex = qr/(\d+)/p;
my $subst = '<span>\\1</span>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";