#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\$(\w*)\+\+"
Local $sString = "asdf=5" & @CRLF & _
"$asdf++"
Local $sSubst = "$1=\$(( \$1+1 ))"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)