use strict;
my $str = 'asdf=5
$asdf++';
my $regex = qr/\$(\w*)\+\+/p;
my $subst = '$1=\\$(( \\$1+1 ))';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";