re = /\$(\w*)\+\+/
str = 'asdf=5
$asdf++'
subst = '$1=\\$(( \\$1+1 ))'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result