import re
regex = re.compile(r"\$(\w*)\+\+")
test_str = ("asdf=5\n"
"$asdf++")
subst = "$1=\\$(( \\$1+1 ))"
result = regex.sub(subst, test_str)
if result:
print(result)