#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ".*(IP:[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3})(Hostname:.*)(Model:\d+)"
Local $sString = """:"<ahref="#"class="tree-title"title="IP:10.0.0.1Hostname:hello1Model:2901Version:1.1.1.1_80000State:Normal">hello1(10.0.0.1)</a>"},{"":"<ahref="#"class="tree-title"title="IP:10.0.0.2Hostname:hello2Model:2911Version:1.1.1.1_80000State:Normal">hello2(10.0.0.2)</a>"},{"":"<ahref="#"class="tree-title"title="IP:10.0.0.3Hostname:hello3Model:2911Version:1.1.1.1_80000State:Normal">hello3(10.0.0.3)</a>"},{"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")