using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*(IP:[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3})(Hostname:.*)(Model:\d+)";
string input = @""":""<ahref=""#""class=""tree-title""title=""IP:10.0.0.1Hostname:hello1Model:2901Version:1.1.1.1_80000State:Normal"">hello1(10.0.0.1)</a>""},{"":""<ahref=""#""class=""tree-title""title=""IP:10.0.0.2Hostname:hello2Model:2911Version:1.1.1.1_80000State:Normal"">hello2(10.0.0.2)</a>""},{"":""<ahref=""#""class=""tree-title""title=""IP:10.0.0.3Hostname:hello3Model:2911Version:1.1.1.1_80000State:Normal"">hello3(10.0.0.3)</a>""},{";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}