const regex = /.*(IP:[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3})(Hostname:.*)(Model:\d+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*(IP:[0-9]{1,3}\\.[0-9]{1,3}\\.[0-9]{1,3}\\.[0-9]{1,3})(Hostname:.*)(Model:\\d+)', 'g')
const str = `"":"<ahref="#"class="tree-title"title="IP:10.0.0.1Hostname:hello1Model:2901Version:1.1.1.1_80000State:Normal">hello1(10.0.0.1)</a>"},{"":"<ahref="#"class="tree-title"title="IP:10.0.0.2Hostname:hello2Model:2911Version:1.1.1.1_80000State:Normal">hello2(10.0.0.2)</a>"},{"":"<ahref="#"class="tree-title"title="IP:10.0.0.3Hostname:hello3Model:2911Version:1.1.1.1_80000State:Normal">hello3(10.0.0.3)</a>"},{`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}