$re = '/.*(IP:[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3})(Hostname:.*)(Model:\d+)/';
$str = '"":"<ahref="#"class="tree-title"title="IP:10.0.0.1Hostname:hello1Model:2901Version:1.1.1.1_80000State:Normal">hello1(10.0.0.1)</a>"},{"":"<ahref="#"class="tree-title"title="IP:10.0.0.2Hostname:hello2Model:2911Version:1.1.1.1_80000State:Normal">hello2(10.0.0.2)</a>"},{"":"<ahref="#"class="tree-title"title="IP:10.0.0.3Hostname:hello3Model:2911Version:1.1.1.1_80000State:Normal">hello3(10.0.0.3)</a>"},{';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);