#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)<section .*?class="product".*?>\s*<h3>\s*(.+?)\s*<\/h3>.*?<\/section>\s*|<art .*?id="src".*?>"
Local $sString = "<art id="src">" & @CRLF & _
" <section class="product">" & @CRLF & _
" <h3>xvd</h3>" & @CRLF & _
" <p>" & @CRLF & _
" sjfdsjvdvds" & @CRLF & _
" </p>" & @CRLF & _
" </section>" & @CRLF & _
" <section class="product">" & @CRLF & _
" <h3>avdsvd</h3>" & @CRLF & _
" <p>" & @CRLF & _
" djsfdsjgdjs" & @CRLF & _
" </p>" & @CRLF & _
" </section>" & @CRLF & _
" <section class="product">" & @CRLF & _
" <h3>zdvdsv</h3>" & @CRLF & _
" <p>" & @CRLF & _
" safdgdsghhrh" & @CRLF & _
" </p>" & @CRLF & _
" </section>" & @CRLF & _
" <section class="product">" & @CRLF & _
" <h3>dd</h3>" & @CRLF & _
" <p>zscsvdsvdsv</p>" & @CRLF & _
" </section>" & @CRLF & _
"</art>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")