import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<section .*?class=\"product\".*?>\\s*<h3>\\s*(.+?)\\s*<\\/h3>.*?<\\/section>\\s*|<art .*?id=\"src\".*?>";
final String string = "<art id=\"src\">\n"
+ " <section class=\"product\">\n"
+ " <h3>xvd</h3>\n"
+ " <p>\n"
+ " sjfdsjvdvds\n"
+ " </p>\n"
+ " </section>\n"
+ " <section class=\"product\">\n"
+ " <h3>avdsvd</h3>\n"
+ " <p>\n"
+ " djsfdsjgdjs\n"
+ " </p>\n"
+ " </section>\n"
+ " <section class=\"product\">\n"
+ " <h3>zdvdsv</h3>\n"
+ " <p>\n"
+ " safdgdsghhrh\n"
+ " </p>\n"
+ " </section>\n"
+ " <section class=\"product\">\n"
+ " <h3>dd</h3>\n"
+ " <p>zscsvdsvdsv</p>\n"
+ " </section>\n"
+ "</art>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}