$re = '/<section .*?class="product".*?>\s*<h3>\s*(.+?)\s*<\/h3>.*?<\/section>\s*|<art .*?id="src".*?>/s';
$str = '<art id="src">
<section class="product">
<h3>xvd</h3>
<p>
sjfdsjvdvds
</p>
</section>
<section class="product">
<h3>avdsvd</h3>
<p>
djsfdsjgdjs
</p>
</section>
<section class="product">
<h3>zdvdsv</h3>
<p>
safdgdsghhrh
</p>
</section>
<section class="product">
<h3>dd</h3>
<p>zscsvdsvdsv</p>
</section>
</art>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);