package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)<section .*?class="product".*?>\s*<h3>\s*(.+?)\s*<\/h3>.*?<\/section>\s*|<art .*?id="src".*?>`)
var str = `<art id="src">
<section class="product">
<h3>xvd</h3>
<p>
sjfdsjvdvds
</p>
</section>
<section class="product">
<h3>avdsvd</h3>
<p>
djsfdsjgdjs
</p>
</section>
<section class="product">
<h3>zdvdsv</h3>
<p>
safdgdsghhrh
</p>
</section>
<section class="product">
<h3>dd</h3>
<p>zscsvdsvdsv</p>
</section>
</art>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}