using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!(-|_))(?!.*(--|__))[A-Za-z0-9-_]+(?<!(-|_))$";
string input = @"549t58j429
GX22-304
PM508_431_13
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}