re = /^(?!(-|_))(?!.*(--|__))[A-Za-z0-9-_]+(?<!(-|_))$/m
str = '549t58j429
GX22-304
PM508_431_13
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end