const regex = /^(?!(-|_))(?!.*(--|__))[A-Za-z0-9-_]+(?<!(-|_))$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!(-|_))(?!.*(--|__))[A-Za-z0-9-_]+(?<!(-|_))$', 'gm')
const str = `549t58j429
GX22-304
PM508_431_13
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}