$re = '/^(?!(-|_))(?!.*(--|__))[A-Za-z0-9-_]+(?<!(-|_))$/m';
$str = '549t58j429
GX22-304
PM508_431_13
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);