#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^Dealer:"
Local $sString = "Dealer: callawaykid wins 428 chips" & @CRLF & _
"Dealer: ** Hand [ 1288159259 ] started **" & @CRLF & _
"Dealer: Dealt to board: [ 4h Qh 2c ]" & @CRLF & _
"Dealer: Dealt to board: [ 8h ]" & @CRLF & _
"Dealer: Dealt to board: [ 6d ]" & @CRLF & _
"Dealer: Showdown: Main pot, 380 chips" & @CRLF & _
"Dealer: centraliaxxx mucks" & @CRLF & _
"Dealer: centraliaxxx wins 380 chips" & @CRLF & _
"Dealer: ** Hand [ 1288159639 ] started **"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")