import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^Dealer:";
final String string = "Dealer: callawaykid wins 428 chips\n"
+ "Dealer: ** Hand [ 1288159259 ] started **\n"
+ "Dealer: Dealt to board: [ 4h Qh 2c ]\n"
+ "Dealer: Dealt to board: [ 8h ]\n"
+ "Dealer: Dealt to board: [ 6d ]\n"
+ "Dealer: Showdown: Main pot, 380 chips\n"
+ "Dealer: centraliaxxx mucks\n"
+ "Dealer: centraliaxxx wins 380 chips\n"
+ "Dealer: ** Hand [ 1288159639 ] started **";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}