use strict;
my $str = 'Dealer: callawaykid wins 428 chips
Dealer: ** Hand [ 1288159259 ] started **
Dealer: Dealt to board: [ 4h Qh 2c ]
Dealer: Dealt to board: [ 8h ]
Dealer: Dealt to board: [ 6d ]
Dealer: Showdown: Main pot, 380 chips
Dealer: centraliaxxx mucks
Dealer: centraliaxxx wins 380 chips
Dealer: ** Hand [ 1288159639 ] started **';
my $regex = qr/^Dealer:/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}