import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\n{2,}|\\A)\n"
+ "(?<code_all>\n"
+ " (?:\n"
+ " (?<code_prefix>\n"
+ " [ ]{4}\n"
+ " |\n"
+ " \\t\n"
+ " )\n"
+ " (?<code_content>.*\\n+)\n"
+ " )+\n"
+ ")\n"
+ "(?<code_after>\n"
+ " (?=^[ ]{0,4}\\S)\n"
+ " |\n"
+ " \\Z\n"
+ ")";
final String string = " Codeblock on second line\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}