// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mx)(?:\n{2,}|\A)
(?<code_all>
(?:
(?<code_prefix>
[ ]{4}
|
\t
)
(?<code_content>.*\n+)
)+
)
(?<code_after>
(?=^[ ]{0,4}\S)
|
\Z
)").unwrap();
let string = " Codeblock on second line
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}