$re = '/(?:\n{2,}|\A)
(?<code_all>
(?:
(?<code_prefix>
[ ]{4}
|
\t
)
(?<code_content>.*\n+)
)+
)
(?<code_after>
(?=^[ ]{0,4}\S)
|
\Z
)/mx';
$str = ' Codeblock on second line
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);