re = /(?:\n{2,}|\A)
(?<code_all>
(?:
(?<code_prefix>
[ ]{4}
|
\t
)
(?<code_content>.*\n+)
)+
)
(?<code_after>
(?=^[ ]{0,4}\S)
|
\Z
)/mx
str = ' Codeblock on second line
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end