#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<![^\W_])(?:lemon|apple|coconut)(?![^\W_])"
Local $sString = "/var/prj/lemon_123/xyz" & @CRLF & _
"/var/prj/123_apple/coconut" & @CRLF & _
"/var/prj/lemonade/coconutapple" & @CRLF & _
"/var/prj/apple/lemon"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")