const regex = new RegExp('(?<![^\\W_])(?:lemon|apple|coconut)(?![^\\W_])', 'gm')
const str = `/var/prj/lemon_123/xyz
/var/prj/123_apple/coconut
/var/prj/lemonade/coconutapple
/var/prj/apple/lemon`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}