import re
regex = re.compile(r"(?<![^\W_])(?:lemon|apple|coconut)(?![^\W_])", flags=re.MULTILINE)
test_str = ("/var/prj/lemon_123/xyz\n"
"/var/prj/123_apple/coconut\n"
"/var/prj/lemonade/coconutapple\n"
"/var/prj/apple/lemon")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")