import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<![^\\W_])(?:lemon|apple|coconut)(?![^\\W_])";
final String string = "/var/prj/lemon_123/xyz\n"
+ "/var/prj/123_apple/coconut\n"
+ "/var/prj/lemonade/coconutapple\n"
+ "/var/prj/apple/lemon";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}