import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\bhttps?://\\S+/)[^\\s?#/]+(?![^\\s?#])";
final String string = "For any of the following URLs, I'm looking for a match for segment as follows:\n\n"
+ " https://example.com/what-not/segment matches segment\n"
+ " https://example.com/what-not/segment?a=b matches segment\n"
+ " https://example.com/what-not/segment#a matches segment\n\n"
+ "In case there is a match for segment, I'm going to replace it with segment/.\n\n"
+ "For any of the following URLs, there should be no match:\n\n"
+ " https://example.com/what-not/segment/ no match\n"
+ " https://example.com/what-not/segment/?a=b no match\n"
+ " https://example.com/what-not/segment/#a no match\n";
final String subst = "$1segment/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}