re = /(?<=\bhttps?:\/\/\S+\/)[^\s?#\/]+(?![^\s?#])/m
str = 'For any of the following URLs, I\'m looking for a match for segment as follows:
https://example.com/what-not/segment matches segment
https://example.com/what-not/segment?a=b matches segment
https://example.com/what-not/segment#a matches segment
In case there is a match for segment, I\'m going to replace it with segment/.
For any of the following URLs, there should be no match:
https://example.com/what-not/segment/ no match
https://example.com/what-not/segment/?a=b no match
https://example.com/what-not/segment/#a no match
'
subst = '$1segment/'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result