use strict;
my $str = 'For any of the following URLs, I\'m looking for a match for segment as follows:
https://example.com/what-not/segment matches segment
https://example.com/what-not/segment?a=b matches segment
https://example.com/what-not/segment#a matches segment
In case there is a match for segment, I\'m going to replace it with segment/.
For any of the following URLs, there should be no match:
https://example.com/what-not/segment/ no match
https://example.com/what-not/segment/?a=b no match
https://example.com/what-not/segment/#a no match
';
my $regex = qr/(?<=\bhttps?://\S+/)[^\s?#/]+(?![^\s?#])/mp;
my $subst = '$1segment/';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";