using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[-+]?\d{1,2}\.\d+,[-+]?\d{1,3}(\.\d+)?$";
string input = @"-34.654,-654.764";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}