// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^[-+]?\d{1,2}\.\d+,[-+]?\d{1,3}(\.\d+)?$").unwrap();
let string = "-34.654,-654.764";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}