$re = '/^[-+]?\d{1,2}\.\d+,[-+]?\d{1,3}(\.\d+)?$/';
$str = '-34.654,-654.764';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);