package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[-+]?\d{1,2}\.\d+,[-+]?\d{1,3}(\.\d+)?$`)
var str = `-34.654,-654.764`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}