#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[a-zA-Z]+(?: [a-zA-Z]+)+"
Local $sString = "Jean Acker " & @CRLF & _
"Mary Kay Adams" & @CRLF & _
"Elizabeth Allen Alba Bailey" & @CRLF & _
"Blanche Baker Bowen Collinge Marie" & @CRLF & _
"" & @CRLF & _
"Ryan" & @CRLF & _
"Filbert77" & @CRLF & _
"Mark 21" & @CRLF & _
"Franz.Dimaz"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")