$re = '/[a-zA-Z]+(?: [a-zA-Z]+)+/m';
$str = 'Jean Acker
Mary Kay Adams
Elizabeth Allen Alba Bailey
Blanche Baker Bowen Collinge Marie
Ryan
Filbert77
Mark 21
Franz.Dimaz';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);