import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[a-zA-Z]+(?: [a-zA-Z]+)+";
final String string = "Jean Acker \n"
+ "Mary Kay Adams\n"
+ "Elizabeth Allen Alba Bailey\n"
+ "Blanche Baker Bowen Collinge Marie\n\n"
+ "Ryan\n"
+ "Filbert77\n"
+ "Mark 21\n"
+ "Franz.Dimaz";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}