re = /[a-zA-Z]+(?: [a-zA-Z]+)+/m
str = 'Jean Acker
Mary Kay Adams
Elizabeth Allen Alba Bailey
Blanche Baker Bowen Collinge Marie
Ryan
Filbert77
Mark 21
Franz.Dimaz'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end