import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "From:\\s+(?<from>.*?)\\s+To:\\s+(?<to>.*?)\\s+Subject:\\s+(?<subject>.*?)(?:\\s+References: (?<ref>.*?))?$";
final String string = "Text of variable length spread across several lines Serialization-type text separated by colons (eg ABC:DEF:GHI) A date\n\n"
+ "From: One line of text To: One or more lines Subject: One or more lines References: One or more lines\n\n"
+ "From: One line of text To: One \n"
+ "or \n"
+ "more \n"
+ "lines Subject: One or more lines References: One or more lines\n\n"
+ "From: One line of text To: One or more lines Subject: No references.\n\n"
+ "From: One line of text To: One or more lines Subject: One \n"
+ "or \n"
+ "more \n"
+ "lines \n"
+ "References: One or more lines\n\n"
+ "Paragraph 1 Title: A paragraph\n\n"
+ "Paragraph 2 Title: Another paragraph";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}